Kada u Joomli uključim Eearch Engine Friendly URLs ne radi mi ceo sajt

Imam problem sa joomla.
Naime kada postavim u global configuration da bude štiklirano Yes Search Engine Friendly URLs. Onda mi ne radi ceo sajt.

Koji problem bi mogao da bude, kako da ga rešim?

[color=green]Prvo napiši sadržaj poruke, a onda iz njega sastavi naslov teme kako sam ti ovaj puta pokazao primjerom.[/color]

Isti problem imao sam i ja, i nikada ga nisam znao rješit. Jednostavno sam isključio taj Friendly URL, i radio bez njega. Ako neko zna rješenje za ovaj problem, bio bi i meni od koristi.

Može biti da postoji problem s datotekom .htaccess. Taj modul/plugin vjerojatno pokušava promijeniti tu datoteku, a ona ili ne postoji ili aplikacijama nije omogućeno njezino mijenjenje. Dakle, treba ili ručno kreirati .htaccess s potrebnim sadržajem ili promijeniti chmod za tu datoteku.

Imao sam takav problem s Wordpressom. Riješio sam ga na gore opisani način.

da li je kod tebe windows ili linux hosting?

Search Engine Friendly URL drugacije rade na linux od onih na windows OS-u.

linux. Nego ima li neko neki plugin za to - da zameni Search Engine Friendly URLs.

linux. Nego ima li neko neki plugin za to - da zameni Search Engine Friendly URLs…

Da bi stvar radila, datoteku htaccess.txt treba preimenovati u .htaccess (često je u tome problem)

A evo kako treba izgledati navedena datoteka:

##
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##
#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################
##  Can be commented out if causes errors, see notes above.
Options +FollowSymLinks
#
#  mod_rewrite in use
RewriteEngine On
########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits
#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)
# RewriteBase /
########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Inače postoji brdo pluginova i komponenti ovdje, a JomSEF sam i osobno koristio neko vrijeme, a i vidim da je poprilično rasprostranjen i popularan… Btw, nisam siguran za ostale, ali JomSEF neće raditi ako nisu zadovoljeni uvjeti koje sam naveo gore…

U pravu si.Svi koji imaju isti problem neka znaju:
Preimenujte .htaccess.txt (.htaccess) u htacces
Ukljucite mod rewite
Ukljucite Seach Engine Frendly URLS

I radice vam.

Hvala vam sto ste mi pomogli.

[quote=""]Imam problem sa joomla.
Naime kada postavim u global configuration da bude štiklirano Yes Search Engine Friendly URLs. Onda mi ne radi ceo sajt.

Koji problem bi mogao da bude, kako da ga rešim? [/quote]

[quote=“1vca”]U pravu si.Svi koji imaju isti problem neka znaju:
Preimenujte .htaccess.txt (.htaccess) u htacces
Ukljucite mod rewite
Ukljucite Seach Engine Frendly URLS
[/quote]
Hm, kad si već štiklirao Yes Search… zar nisi mogap procitati i upute koje se nalaze 4 mm desno. Odgovor je na razini da li si upalio monitor.

ja ne razumijem zar je toliko teško bilo pročitati readme?
Mislim ja sam prvi put instalriao joomlu i to za preimenovanje datoteke mislim da piše odmah pored checkboxa, pa jeste li toliko glupi, blesavi, lijeni (ispričavam se, ali neznam kak drugačije da to nazovem, da niste mogli pročitati jednu rečenicu teksta?)
trebalo je samo mišem prijeći na znak upozorenja, velika mudrost…

fazon je u tome sto sam ja pred zadnji put instalirao joomlu prosle godine tada sam za to znao, sada sam zaboravio.

Pozdrav. Jeste da je tema starija, ali imam sličan problem. Meni ne rade search friendly url iako je preimenovan htaccess.txt u .htaccess. Znači ne radi mi ni kad je upaljen samo search friendly url, a nije upaljen apache rewrite mod. Imao sam iskustava da na hostingu ne radi rewrite mod i onda ostavim samo uključen search friendly url i to je to. No sad mi neće ni tako.

hm, mislim da za tvoj problem trebaš u samom htaccess fajlu podasiti parametre.

Šta bi trebalo promijeniti? Nisam nikad čačkao po htaccessu.

Evo i samog koda .htacces fajla.

##
# @version		$Id: htaccess.txt 20196 2011-01-09 02:40:25Z ian $
# @package		Joomla
# @copyright	Copyright (C) 2005 - 2011 Open Source Matters. All rights reserved.
# @license		GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
## End - Rewrite rules to block out some common exploits.

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/component/) [OR]
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
## End - Joomla! core SEF Section.

Pozdrav. Problem što mi u Joomli ne rade search friendly url je što je sajt na Nginx serveru. Ako neko zna kako da premostim taj problem neka kaže.


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Webmaster.Ninja