Pitanja oko https


#21

Evo i to sam uradio, ali jutros sajta nema u prvih 20 stranica na Google. Baš mi nije jasno kako se ovo desilo.


#22

popravit ce se ne brini


#23

Mogu ja uletit?

Imam 2 razlicite stranice:

  1. WP
  2. Forum

Za CDN znam staviti, ali hocu da sa CDN-om bude i ssl tipa lets encrypt, neznam ni sam jeli Cloudflare nudi free ssl, mislim da ne, uglavnom kako to dvoje iskombinirat?


#24

Da ima free od https://www.cloudflare.com/plans/ ja sam ga probao koristiti namjestio sve prema uputuma i pisalo je da je on aktive međutim na webu mi nije radio https i to nisam nikako mogao srediti… Tako da sam udlučio platiti svom provideru i bilo mi aktivno za 2 sata i odjednom proradio https


#25

koji cms koristiš? …


#26

Wordpress,Wordpress,Wordpress,Wordpress,


#27

Jesi čekao da prođe 24 sata?


#28

jesi li siguran da si u podešavanjima linkove prebacio na https? Je li ti uopšte otvaralo kada ukucaš https://site


#29

40


#30

Da čekao sam skoro 2 dana i ništa se nije promjenilo u mom slučaju. Sinoć oko 9 navečer sam naručio preko svog providera već ujutro mi je sve bilo aktivno… Ništa nisam morao namještati jer sam sve linkove prebacio na https još kad sam pokušao preko cloudflare…

Nekažem da neradi nego jednostavno za mene nije radilo nije mi se dalo dublje ulaziti u to jer sam vidio da je bilo puno sličnih slučajeva i jednostavno sam se odlučio na ovu opciju i gg.


#31

dugo vremena nisu imali ssl


#32

Imam Flexible ssl na cloudflare, stavio sam u Wp-> General u 2 polja umjesto http -> https i pise mi:

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

Kako rijesiti ovaj problem?


#33

vrati ta dva polja na http i instaliraj

pa onda ponovo u ta dva polja upiši https i sačuvaj

imao sam isti problem, tako riješio

edit: pošto ne možeš vratiti jer ti izbacuje taj problem morat ćeš u bazi promijeniti u http


#34

Jesam tako se i vracam nazad, dodao sam u wp configu:

define(‘WP_HOME’,‘http:// XXX .com’);

define(‘WP_SITEURL’,‘http:// XXX .com’);

Ali u General ne mogu promjeniti url zatamljen je. Instalirao sam taj plugin i ne vidim opcije. Racunam da je on sam nesto uradio, pa micem dodani kod iz wp configa, ali onda mi ne mogu uci u stranicu jer mi pise taj gore error.


#35

vrati te dvije linije koda samo promijeni http u https, trebalo bi da u zatamnjenim poljima bude https logično

ako ni to ne bude radilo ostavi te dvije linije sa http, ostavi instaliran plugin a skrolaj na cloudflareu pod Crypto dole nađi i uključi Automatic HTTPS Rewrites a pod page rules dodaj novi rule, prilikom ubacivanja novog rulea pod If the URL matches stavi http://domena.com/* a pod Then the settings are stavi Always use HTTPS … i onda promijeni te dvije linije koda u https

ovdje opširnije:


#36

Hvala, radi medutim ima nekih slika koliko vidim http://prntscr.com/ifpy9i koje nisu sigurne, otvara sve u https medutim nema mi zelene one ikone, jeli moguce ikako naci rijesenja za to?


#37

@CroLog malo pripazi molim te i gledaj da ti postovi više ne izgledaju ovako, s ovakvim linkovima. Općenito molim izbjegavajte neispravne linkove, a pogotovo ovakve. :frowning:
bad-links
Hvala. :o:


#38

probaj pa javi koji od ova dva radi


#39

Neradi nijedan :frowning:

Sada vidim da mi jos ne radi Yottie plugin https://codecanyon.net/item/youtube-plugin-wordpress-gallery-for-youtube/14115701

I jos 1 skripta van wordpressa koja se nalazi na link.com/skripta

Edit:
Rijesio Yottie, iskljucio sam Minify u Wp Rocket pluginu.

Jeli mogu nekako excludati link.com/skripta da ne koristi https? Nemam vise page pravila u cloudflare jer sam vec imam 3:

wp login
wp admin
http://link.com/*