Server odjednom spor

Imam server sa par sajtova koji hendlaju desetine tisuca posjeta dnevno. Danas poslijepodne je poceo stucati, nekad se otvara po 50 sekundi, a nekada odmah.

Server support kaze da koristim gotovo svih 16GB memorije sto mi je suludo jer sajtovi nisu nista specijalno zahtjevni, vecinom staticni na Wordpressu. Imaju relativno puno slika ali mislim da to ne bi trebao biti problem jer su mi posjete stabilne, tj jucer je bila ista posjeta kao danas i ista posjeta kao prije mjesec dana, a prije nije stucalo, sad stuca. W3 total cache sam imao ali iskljucio davno jer nije potreban. Server je prejak. Sta bi mogao biti problem? Dal bi reboot pomogao? Mozda se nakupilo nekog sranja, nemam pojma.

Dal cu morati instalirati W3 total cache? Ne sjecam se zasto sam ga obrisao ali bio je neki razlog. Naravno i bez tog plugina su sajtovi derali superbrzo sve do danas.

Ako imas mnogo staticnog sadrzaja, mislim da bi odlicno resenje bio cloudflair. Mada mislim da ti je to ipak do prevelikog broja upita, pa ne bi bilo lose da se kod optimizuje

Evo stavio sam w3 total cache i popravilo se, mada cudno mi da je do sad bez njega radilo full normalno, a nisam bas dobio neke nove posjete. Mozda nekih 5% vise posjete u zadnjih par dana.

Hmm, i dalje imam problem. Jako je cudno. Sajt kad radi onda dere u 2 sekunde se otvara, ali svakih 5-6 loadanja naleti da nece da otvori po 30 sekundi ili minutu :frowning:

To ti je do WordPressa jer si dodao vise od 5 postova, a to inace zna biti kobno po server i same pefromanse.

Vjerovatno te Server Support malo vuce za nos, mislim ako nisi vrsio neke drasticne izmjene a brzina stranica vidno pala nema sta drugo biti.

Vise od 5 postova wtf? Ne razumijem.

Prije ovoga sam imao nekih 500 postova, zadnji mjesec sam nagurao na 600.

To su legende o WordPress-u.

Jednostavno nemoguce ako je server ok. Jesi li mjerio ping, te dl/ul?

Sad radi skroz normalno :confused:

Load time: 3.52s
Page size: 947.2kB
Ping: 35ms

Mozda se nesto jucer desavalo sa mrezom ili serverom, a support je izgleda nestrucan jer rekli su mi da sam koristio cijeli ram, a Linux inace posudjuje nekoristenu memoriju za disk caching. Ta memorija izgleda zauzeto ali cim necemu zatreba ona se oslobadja.

Valjda ce biti ok sada.

Evo opet mi je usporio nenormalno, nekada sajt ne moze uopce da ucita.

A resursi servera uopce nisu tako visoko iskoristeni:

Server Load 0.75 (8 CPUs)
Memory Used 13.04% (2,121,340 of 16,267,596)
Swap Used 1.86% (156,336 of 8,388,600)

Ne shvatam zasto. Cekam odgovor supporta ali uvijek se nekako izmotaju ili se problem rijesi sam nakon par sati.

I sad je spontano prestalo opet. Kako me zivcira.

Pregledaj malo file-ove na serveru, moguće je da si pokupio nekakav malware.

Drugo, ukoliko koristiš VPS, pogledaj apache error logove.

I treće, pogledaj http://tools.pingdom.com/fpt/ i pregledaj da li ti neki file ima prevelik loading time, odnosno da li dohvačaš sve skripte ? Možeš na FireBug-u ili sličnim toolovima, pogledati broj errora na stranici.

Hvala na savjetima. Externi sken je pokazao da nema malware. A sad po fajlovima bas i ne znam pregledati, ima ih milion.

Server je dedicated.

Opet mi je down, 503 service unavailable, nekad otvori nekad ne. Uocio sam ovo: http://i.imgur.com/aF42yoy.jpg

Da li je mozda do updateanja bandwith podataka? awstats

WHM -> Service Configuration -> Statistics Software Configuration and in the bottom-right corner of the page click the “Configure Statistic Process Time Schedule” button. Simply check the hours it should not run, click save. It is best to be very conservative with regards to setting which hours the software is not permitted to run, because if you exclude too many hours your statistics run may never complete and website statistics may not be properly generated for all cPanel accounts on the server.

Evo i zvanicno kako podesiti od cPanel https://documentation.cpanel.net/display/ALD/Schedule+Configuration

Imas i ovo https://forums.cpanel.net/threads/configure-cpanellogd-via-command-line.320591/

Kaze mi iz supporta da ima masu procesa koji odu u sleep http://i.imgur.com/R3tJNWG.jpg

Kao lose napisane php skripte. Ne znam onda zasto se ovo ne desava stalno nego svakih 5 dana. A prije se nije desavalo uopce.

“sleep state means that MySQL process has done with its query, but the client-side did not yet exit. Many web applications don’t clean up their connections afterwards, which leads to sleeping MySQL processes. Don’t worry if there are only handful of them; MySQL will clean up those after a configurable timeout period (wait_timeout).”

mozda treba taj wait timeout smanjiti? Kako sam neuk oko ovih stvari :confused:

Recimo sad server skroz normalno radi. Kao da nista nije bilo.


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Profit Monkey