Wordpress 3.0.3 zeznuo nase znakove!

Uradim update na verziju 3.0.3 i zezne mi sve nase znakove. Na internetu sam pronasao dva rjesenja koja mi nisu pomogla.

http://hajdarovic.com/2007/12/30/wordpress-problemi-sa-hrvatskim-dijakritickim-znakovima/

http://www.croitportal.com/web-razvoj/tutorijali/wordpress-tutorijali/146-wordpress-i-dijakriticka-slova-

Pokusao sam instalirati alat Search and Replace (
http://wordpress.org/support/topic/moved-entire-blog-now-special-characters-wont-display-right
) da mi u bazi zamijeni sve poremecene znakove, ali nije pomogao jer ne pronalazi trazeni pojam.

Zatim sam u bazi direktno pokusao promijeniti znakove SQL naredbom

UPDATE wp_posts SET post_content = replace(post_content, 'ć' 'ć', '')

ali mi se sada javlja poruka

Zna li mi itko pomoci? Postova je previse da ih sam prepravljam. :frowning:

jel koristiš jezik s


?

[quote=“Exdizajn”]jel koristiš jezik s


?[/quote]

Nisam. Koristim engleski Wordpress a u fileu wp-config.php do sada su bile komentirane linije

/** Database Charset to use in creating database tables. */
//define('DB_CHARSET', 'utf-8');

/** The Database Collate type. Don't change this if in doubt. */
//define('DB_COLLATE', ''); 

i sve je super radilo. Jutros uradio upgrade i sva nasa slova u svim postovima se poremetila.

Odi opet u wp-config.php i obrati pažnju na;

Pogledaj dali postoji (minus) utf-8 , ako ga nema stavi ga i raditi će.

meni normalno radi i na rh i na eng.

[quote=“webjumfer”]Odi opet u wp-config.php i obrati pažnju na;

Pogledaj dali postoji (minus) utf-8 , ako ga nema stavi ga i raditi će.[/quote]

Minus nije postojao pa sam ga ja prema savjetu pod 2 stavio. medjutim slova ne rade niti kada je kod komentiran niti kada nije komentiran.

Nisam pocetnik u WP-u tako da 100% nisam nista cackao pa zeznuo. Bukvalno sam otisao na UPDATE i paf - kvacice nestale. :krele:

Da se ispravim, nasa slova RADE u naslovima, a NE RADE samo u tijelu posta. Ma sto se ovo dogadja???

Isto kada u bazi rucno ispravim slovo u nase slovo, ono se PRAVILNO prikaze. Izgleda da je greska samo u parsiranju tj. na putanju publish post -> save it to table.

Evo nekih rijeci:
važni = važni
lakÅ¡a = lakši
proÄ�itat = pročitati
ćete = ćete

Ja sam početnik al sam imao na samom početku takav problem. A otklonio sam ga što sam stavio (-), al nije mi više ispravio stari tekst kak je bio nego sam morao sve ponovo ručno ispravljati…

Ja sam to odmah promijenio i onda sam testirao na novom postu (jer se valjda stari moraju rucno izmijeniti), ali i kod novog se dijakriticki znakovi u naslovu fino prikazu, a u tijelu nisu.

Probaj maknuti ove prve dvije kose crte, ja ih nemam

//define(‘DB_CHARSET’, ‘utf-8’);

Jesam. To je bila fora iz prijasnjih verzija Wordpressa. Sada je vajda samo trebalo ispraviti utf8 u utf-8.

Sad ti je problem sto neces moci promjeniti slova automatski, nego samo rucno. Ista stvar se meni dogodila, ali posto mi ta stranica ne donosi neku zaradu, nisam se htio zafrkavati s tim.

Idi u Settings > Reading

Što ti tu piše za “Encoding for pages and feeds” ?

Također je moguce da je negdje u tvom template-u hardkodiran neki drugi encoding, što ti kaže kada odeš u frontendu na view source?

[quote=“w00t”]Idi u Settings > Reading

Što ti tu piše za “Encoding for pages and feeds” ?

Također je moguce da je negdje u tvom template-u hardkodiran neki drugi encoding, što ti kaže kada odeš u frontendu na view source?[/quote]

Encoding for pages and feeds: UTF-8

U sourceu pise ovo:

A tema je Mystique.

Gle, rucno mi ne radi. Ako odem na Edit Post, onda su sve kvacice na mjestu. Ako pokusao u bazi preko SQL koda, javlja se Error. Jedino rucno na bazi, ali to je fakat nemoguce.

Udi u hosting, cpanel, sql baza od tog wordpressa, promjeni rucno, sve u utf-8, znacis ides stavku po stavku i mjebjas iz latin1 u utf-8. Mozda postoji i jednostavniji nacin, ali ovaki ce ti sigurno raditi.

Mislis ovako nesto za svaku tabelu?

alter table wp_posts
CHARACTER SET utf8 
COLLATE utf8_general_ci

ili

alter table wp_posts
CHARACTER SET utf8 
COLLATE utf8_unicode_ci

uđeš u cpanel pa u Databases - phpMyAdmin
uđeš u wordpress i polako mijenjaš. Evo ti slika da bude jasnije.
Znači sve ti mora biti UTF-8

http://img26.imageshack.us/img26/3131/datavw.jpg

Ok hvala. Znam to uraditi samo nisam znao je li koristiti general collation ili neku drugu.

Ovo sam uradio:

  1. Prebacio sve tabele u bazi u UTF-u, collation utf8_general_ci

  2. Preko SQL koda zamijenio sve simbole našim dijakritičkim znakovima

  3. u fajlu wp-config.php prepravio linije i aktivirao ih

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf-8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ‘’);

Sada imam samo neke naše znakove tj. umjesto đ, č, ć je upitnik (?), dok se npr. slovo š fino prikaze. Sto sada? :frowning: :frowning:


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Webmaster.Ninja