Wordpress-na računalu-pad localhosta

zašto pada localhost kada se u

Postavke > Stalne veze…
iz…

Predpodešeno
promijeni u…

Prilagodi strukturu
upišem… /%postname%/

snimim…i

Server error!
Error 500

[quote=“blum”]zašto pada localhost kada se u

Postavke > Stalne veze…
iz…

Predpodešeno
promijeni u…

Prilagodi strukturu
upišem… /%postname%/

snimim…i

Server error!
Error 500[/quote]

Nešto nevalja s htaccess fileom najvjerojatnije. da li imaš enabled mod_rewrite?

wordpress koristim par dana…

neznam kakav je to mod…

sad sam pokušao urediti .htaccess

[quote=""]# BEGIN WordPress

RewriteEngine On RewriteEngine na
RewriteBase / RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f RewriteCond% {} REQUEST_FILENAME!-F
RewriteCond %{REQUEST_FILENAME} !-d RewriteCond% {} REQUEST_FILENAME!-D
RewriteRule . RewriteRule. /index.php [L] / Index.php [L]
</ IfModule>

END WordPress # END WordPress[/quote]

al…problem…ne može se spremit kao .htaccess

prije sam i bazu podataka počistio…mislio da je to problem…

ovo mi je drugi put…
što da radim?..

i meni to na localhostu radi kad promjeni strukturu u “custom”

[quote=“blum”]wordpress koristim par dana…

neznam kakav je to mod…

sad sam pokušao urediti .htaccess

al…problem…ne može se spremit kao .htaccess

prije sam i bazu podataka počistio…mislio da je to problem…

ovo mi je drugi put…
što da radim?..[/quote]

Evo ti probaj s ovim .htaccess neke su minorne promjene,
i editiraj to s nekim code editorom, a ne običnim notepadom. On nema tu mogučnost da spremi datotoeku bez naziva

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Mod_rewrite je apache modul koji dopušta prepisivanje url-ova između ostaloga, ne znam koji lokalni server koristiš, da li je to xampp ili nešto takvo ali u svakom slučaju probak proguglati termin enable mod_rewrite on tu_ubaci_naziv_tvog_lokalnog_servera(npr. xampp)

nisam mogao riješiti problem…
morao ponovo na novo instalirati xampp i wordpress…

.htaccess
datoteku sam spremio u notepad ++
mora biti pod navodnicima

no još uvijek me zabrinjata ista stvar…
nakon istalacije datoteku sam stavio i folder gdje imam instaliran wordpress…
i…da provjerima dal radi…neeeee…
dogodila mi se ista stvar…
ljudi…može pomoć

Nije ti aktiviran Apache module:
rewrite_module

Bez toga i ne pokušavaj da praviš htaccess inače ćeš dobiti internal server error 500.

Inače, wordpress automatski generiše htaccess fajl posle podešavanja permanent linkova.

Ne znam napamet za xampp (mrzi me da ga instaliram), ali evo kako se rewrite_module jednostavno aktivira u wamp-u:
Apache->Apache modules->rewrite_module

Apache module: rewrite_module…je aktivan…nema # ispred…ovak izgleda…
LoadModule rewrite_module modules/mod_rewrite.so
što još treba učiniti?

promijenio sam i opciju
AllowOverride None
u
AllowOverride All
i isti problem…error 500
no…uspio sam vratiti na početak…tj…da ne instaliram xampp ponovo…

zna li netko pomoć?

imam instaliran xampp…
napravio sam promjenu…u…xampp/apache/conf/httpd.CONF
redak 122…
LoadModule rewrite_module modules/mod_rewrite.so
te redak 200…
AllowOverride All

slika iz xamppa…

kad…spremam promjene…bacim mi grešku server error 500
kod toga se u wordpressovom folderu stvara .htaccess
sadržaja…

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /xampp/myweb/wordpress/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /xampp/myweb/wordpress/index.php [L]
</IfModule>

# END WordPress

Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Webmaster.Ninja