XML + UTF-8 = flash

Pozdrav svima,
pokušat ću biti što jasniji, imam swf u koji lodiram externi xml file (neku sliku i text)
e sada problem mi je što mi preglednik nerenderira dijakritička slova (č,đ,š,ž …)

evo kako igleda cod

XML:

<?xml version="1.0" encoding="UTF-8"?>

<slideshow>
	<photoX>0</photoX>
	<photoY>20</photoY>
	<textX>0</textX>
	<textY>330</textY>
	<textWidth>850</textWidth>
    <photo>home_images/1.jpg</photo>
	<description>
		<![CDATA[Busovača leži u dolini na značajnom raskrižju cesta Lašvanske i Lepenićke doline. Ovaj divni krajolik odlikuje se blagim brežuljcima oko grada koji lagano prelaze u visoke planine obrasle gustim šumama, bogatim šumskim plodovima i divljaći. Da bismo busovačkoj, a i široj javnosti predstavili prošlost ovoga grada, počet cemo s podrijetlom samoga imena Busovača koje je i te kako zanimljivo.]]>
	</description>
</slideshow>

html:

nerazumijem zašto mi neradi kako treba možda sam nešto zaboravio a i u flashu sam najestio font arial…
ako netko zna neki prijedlog da probam ili bilo kakav savjet bilo bi jako dobro i unaprijed se zahvaljujem.

[quote=“hibernator”]Pozdrav svima,
pokušat ću biti što jasniji, imam swf u koji lodiram externi xml file (neku sliku i text)
e sada problem mi je što mi preglednik nerenderira dijakritička slova (č,đ,š,ž …)

evo kako igleda cod

XML:

<?xml version="1.0" encoding="UTF-8"?>

<slideshow>
	<photoX>0</photoX>
	<photoY>20</photoY>
	<textX>0</textX>
	<textY>330</textY>
	<textWidth>850</textWidth>
    <photo>home_images/1.jpg</photo>
	<description>
		<![CDATA[Busovača leži u dolini na značajnom raskrižju cesta Lašvanske i Lepenićke doline. Ovaj divni krajolik odlikuje se blagim brežuljcima oko grada koji lagano prelaze u visoke planine obrasle gustim šumama, bogatim šumskim plodovima i divljaći. Da bismo busovačkoj, a i široj javnosti predstavili prošlost ovoga grada, počet cemo s podrijetlom samoga imena Busovača koje je i te kako zanimljivo.]]>
	</description>
</slideshow>

html:

nerazumijem zašto mi neradi kako treba možda sam nešto zaboravio a i u flashu sam najestio font arial…
ako netko zna neki prijedlog da probam ili bilo kakav savjet bilo bi jako dobro i unaprijed se zahvaljujem.[/quote]
Da li je i taj xml spremljen u UTF-8 encodingu? To treba provjeriti prvo…


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Webmaster.Ninja