Pitanja oko https


#82

Svuda mi prijavljuje samo jednu sliku kao unsecure, i to logo…
EDIT: Tj. sve slike su mi http. I kad uploadujem novu sliku isto je url slike http, sta moze da bude problem?


#83

Ja sam ubacio plugin Really Simple SSL. Sve fercera bez problema. Što ne probaš sa njim, lako ga je obrisati. 2 min. posla.


#84

Jeronimo, sve smo objasnili baš u ovoj temi. Pročitati barem odavde pa dalje:


Hvala. :blush: :o:


#85

Reseno, instalirao sam plugin i sve je prebaceno :slight_smile:
Hvala @start77


#86

Evo su i oni prešli :slight_smile:


#87

40

stavio je @mestro67 u 29 postu (16 februar) u temi sliku ovu


#88

I dalje mi niej jasno zasto bi recimpo review site ili blog na kojem pisem samo ja bio pod HTTPS osim ako netko iam informacije da ce se HTTP ukinuti?


#89

NI meni to nije jasno. Po meni je https potreban samo za online shopove, forume i slično.


#90

evo mene opet na ovu temu. da li je potrebno odraditi redirekciju iako je wordpress instaliran na https i od početka sajta se koristi https. u search console sam prijavio sve 4 verzije sajta i danas mi dolazi na mejl

Search Console has identified that your site is affected by 1 new Index coverage related issue. This means that Index coverage may be negatively affected in Google Search results. We encourage you to fix this issue.

New issue found:
Redirect error

Ovo obavještenje mi je došlo za property http://www.mojsajt.com

stavio sam u search console preferiranu verziju https://mojsajt.com nisam dodavao onaj kod u htaccess za redirekciju ali ipak obje http versije bez www i sa mi redirektuje https://mojsajt.com

Da li bi trebao dodat onaj kod u htaccess da sve bude ok?


#91

Ako si sve napravio na analyticsu i search konzoli, ne trebaš ništa u htaccessu, u wp-u su ionako url-ovi u bazi.


#92

Kada sam instalirao SSL, upišem link sajta ovako wp-teacher.com i učita mi ga bez SSL-a, međutim kada kliknem na bilo koji članak, na logo, učita mi sajt sa https tj. SSL.

Probao sam uraditi redirect sa http na https metodama koje sam nasao na internetu uređivanjem .htaccess fajla ali neće.

Evo kako izgleda kod u htaccess fajlu.

image


#93

evo moje laičko objašnjenje. kad se uđe sa gugla na sajt prikazuje ga https. tako da ti je to do cache najvjerovatnije pa tebi prikazuje http jer si posjećivao dok je bio sajt http. probaj da očistiš cache sajta ctrl+f5. ja sam imao sličan problem i nikakvo čišćenje cache mi nije radilo dok nisam sve cache pobrisao sa ccleanerom


#94
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Probaj dodati ovo, umjesto tvog koda na prve 3 linije.

Isto tako, probaj u drugom browseru, ili ocisti cache kao sto Anja kaze…


#95

Ne redirecta ti dobro. Testirao sam sa https://httpstatus.io i prikazuje ako upišem http (bez s) kod 200 za http. Odnosno nema preusmjeravanja. Isto tako za https.

Probaj prva 3 reda zamijeniti sa ovim kodom

<IfModule mod_rewrite.c>
	RewriteEngine On
    RewriteCond %{HTTPS} off
		RewriteCond %{HTTP_HOST} !^www\. [NC,OR]
		RewriteCond %{HTTPS_HOST} !^www\. [NC]		
     RewriteRule ^(.*)$ https://www.wp-teacher.com/$1 [L,R=301]
</IfModule>

#96

Pokušao ali ne radi…


#97

Pokušao i to, ne radi…


#98

Uloguj se u wordpress … Settings >> General >> promijeni urlove u https:// … >> Save


#99

Već jesu postavljeni tako


#100

Probaj ostaviti u htaccessu samo ovo od wordpressa. Izmedju #Begin i # End


#101

Provjeri da li su ti na početnoj stranici svi linkovi, ili linkovi fotografija sa https. Imao sam taj problem. Evo ga čeker: