Potrebna pomoc oko php fajla

Imam problem sa jednim fajlom koji zbog nekog razloga radi na jednom hostu normalno dok ne drugom mi izbacuje: ({“SCRIPTDATA”:"",“ERROR”:""})

Znam 100% da taj fajl moze da se pokrene na tom hostu posto sam video da ga koriste osobe koje su na istom tom hostingu.

Ovo je kod: http://pastebin.com/ySZdcaXp

Nisam uspeo da nadjem nikakvu gresku i evo bukvalno ceo dan pokusavam da namestim ovu skriptu, inace kada pokusam da pokrenem skriptu izbaci mi: parse data error: SyntaxError: Unexpected token (

S obzirom da ni jedan drugi fajl ne izbacuje error sem onoga sto sam rekao skoro sigurno je problem do njega.

Ako neko ima vremena neka pogleda kod i da savet bio bi vrlo zahvalan. :smiley:

Iskljuci prijavljivanje greske:

error_reporting(E_ERROR);

Pokusao sam s tim kodom i sa:

error_reporting(0);
@ini_set(‘display_errors’, 0);

Kao i sa:

// Turn off error reporting
error_reporting(0);

Sad jedino ako nema posebno mesto za taj deo koda, nisam bas vest sa php. Pokusao sam na pocetku nakon otvaranja <?php da stavim kod za ukidanje greske.

Po kodu bi rekao da ti je to neki plugin za wordpress ili se gresim?

Ako je za WP, ide ovako:

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

To nije nacin na koji se rijesavaju problemi :slight_smile:

@Lavi na kojoj se tocno liniji javi error, to bi ti trebalo pisati, da ne trazimo po cijelom file-u bezveze.

Nije u pitanju WP plugin.

@apazinjan u tome je fazon da nigde ne prikazuje error u kod, pokazuje gresku kada pokusam da ucitam php fajl u browseru (na jednom hostu, dok na drugom radi ok).

@apazinjan
Da li si procitao ti njegov prvi post?
Problem je kako sam ja shvatio sto na jednom hostingu radi a na drugom ne. Znaci nije greska u liniji koda, vec je greska prilikom pokretanja na drugom hostingu. Koliko sam ja shvatio on nije napisao tu skriptu pa da ima neku gresku u kodu, skripta je vec napisana i savrseno radi na drugom hostingu. Zato sam predlozio da iskljuci greske. To je najlaksi nacin da resi problem, drugi nacin je da odradi prilagodjavanje.

Probaj dodati sledeci kod unutar <?php ...... ?>
header('Content-Type: application/json');

Jesam, ali ne kuzim sta bi dobio sa isljucivanjem prikaza greski?

To je kao da ti se na autu upali lampica, i ti odes kod mehanicara da ti podesi software na autu da ti se vise ne bi palile te lampice.

Ovako na prvu, moguce da su na dva servera razlicite verzije PHP-a pa ga neka sintaksa buni, to je prva stvar na koju bih posumnjao.

Hvala obojici, ovo zadnje sto je markoni82 predlozio je uspelo i sada sve radi. :smiley:


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Profit Monkey