Premjestanje site-a na localhost

Napravio sam download live sitea na moj xampp local host. Backupirao sam mysql bazu i podesio sve postavke za apsolutne linkove, međutim kad u localhostu pozovem site stalno mi vraca na dashboard xamppa. Imao sam i prije taj site na samom pocetku izrade na localhostu i taj radi normalno. U root direktoriju sitea postoji neki htacces file. Kad njega zamjenim sa htacces fajlom iz novog zip instalacijskog fajka skripte tada mi ne ide na dashboard nego otvara stranicu samo ne loada ju dobro, nema slika ne loada neke tablice itd, da li je netko imao slican problem?

Jeli netko imao slucaj da mu xampp stalno vraca na dashboard iako u folderu stanice postoji index.php fajl.

Moguce da ti redirekciju pravi RewriteBase / linija u .htaccess root fajlu. Podesi i direktorijum projekta pa probaj:

RewriteBase /putanja/do/projekta/
#ako je slicno ovom sto sam napisao, ne zaboravi slash na kraju

To moze biti samo jedan direktorijum u bazi xampp-a (npr. /naziv_projekta/) ili neka putanja do projekta kako sam naveo.
Ili postavi ovde sam kod iz .htaccess fajla.

Koja ti je apsolutna putanja u bazi, i gdje si je unio?

Da li je sajt bio u folderu? Ili u rootu public_html servera?

Koja je putanja smještenog downloadanog sajta?

Ovo je .htaccess file

#for best performance enable these mdules
#mod_setenvif.c (setenvif_module)
#mod_headers.c (headers_module)
#mod_deflate.c (deflate_module)
#mod_filter.c (filter_module)
#mod_expires.c (expires_module)
#mod_rewrite.c (rewrite_module)

ExpiresActive on ExpiresByType image/png "access plus 7 day" ExpiresByType image/jpg "access plus 7 day" ExpiresByType image/jpeg "access plus 7 day" ExpiresByType image/gif "access plus 7 day" ExpiresByType image/x-icon "access plus 7 day" ExpiresByType application/x-shockwave-flash "access plus 7 day" Header unset ETag FileETag None RewriteEngine On Options -Indexes
#RewriteBase /
#Adds trailing slash
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_URI} !(\.[a-zA-Z0-9]{1,5}|/|#(.*))$
#RewriteRule ^(.*)$ $1/ [R=301,L]
#Remove trailing slash
#RewriteRule ^(.*)/$ $1 [R=301,L]

RewriteCond %{QUERY_STRING} ^(.*)?gclid=(.*) [OR]
RewriteCond %{QUERY_STRING} ^(.*)?utm_source=(.*) [OR]
RewriteCond %{QUERY_STRING} ^(.*)?fb_action_ids=(.*)
RewriteRule ^(.*)$ index.php?/$1 [L]

# Enforce www
#RewriteCond %{HTTP_HOST} !^www\.
#RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [PT,QSA]

Google Analytics Integration - Added by cPanel.

AddOutputFilterByType SUBSTITUTE text/html Substitute "s|()?||i" # END Google Analytics Integration

Umjesto linije

#RewriteBase /

ako je u root direktorijumu

RewriteBase /

a ako je u subdirektorijumu

RewriteBase /subdir/

Probaj ovako.

Upravo sam sad s programerom skripte rjesavao problem. Site je na live hostu radio. Programer je downloadao na svoj localhost i njemu radi. Onda je taj site vratio na moj localhost i site sad rado. Nemamo pojma kako vjerojatno je negdje puklo u downloadu fajlova ili baze. Iako sam 2 puta radio download.

Vidim da je tema o xampp-u a i problem je rešen, zamolio bih samo urednike ili administratore (ako urednici nemaju dozvolu spajanja topic-a) da spoje ovu temu sa ovom temom : Xampp sve u ovoj temi

Hvala :slight_smile:


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Profit Monkey