Problemi s profilom, avatarom i SEO-friendly linkovima

Dakle primjetio sam da mi je netko mjenjao neke postavke profila na webmajstori forumu. Uglavnom lozinku i slicno nije mjenjao, te koliko vidim nije nikakva steta napravljena.

Uglavnom hocu reci da ako ste mozda dobili od mene nekakvu privatnu poruku ili nešto slično, to nisam bio ja. Isto tako ako sam bilo kome slao nekakve login podatke i slično putem privatne poruke, a isto tako i vi meni, bilo bi dobro da iste promjenite, čisto zbog sigurnosti.

Uglavnom predpostavljam da je lozinku netko pogodio jer nije bila prekomplicirana, a i jako dugo je nisam mjenjao. Uglavnom učite na mojim greškama, a hakeru koji voli gledati po tuđim profilima čestitam :razbi: nikada mi neće biti jasni takvi likovi.

Pozdrav svima

e sada sam jos malo pregledavao sve to, i cini mi se da ova nova struktura linkova na forumu ima veze sa ovim
ovo je link do mog profila (ili bi trebao biti)
Vidi profil: Ivan M - Webmajstori.Net

kao sto vidite, ovo je sasvim drugi user, sa totalno drugim brojem postova i drugacijim potpisom, ali ocito neke stvari iz profila i dijelimo, kao recimo avatar

Ti trebaš imati pingvina za avatara, zar ne?

Mislim da si u pravu – gotovo sigurno se radi o URL-redirekciji, i ja sam primjetio da je mijenjana (npr. “Who’s online” koji prije nije dobro radio, radi dobro).

U tvome je slučaju problem u tome što je iz redirektiranih URL-ova izbačen originalni identifikator (npr. u slučaju linka na korisnikov profil ID korisnika u bazi). To dovodi do toga da ostaje samo “user-friendly” dio koji, koliko god bio user friendly, nije computer friendly, pa se tvoje korisničko ime “ivan.m” i korisničko ime korisnika “Ivan M” u URL-u bilježe na isti način - kao “ivan-m”. S obzirom da sada nedostaje diskriminirajući ID korisnika, sve što je javno (čemu se pristupa kroz URL) se kupi uvijek iz profila tog korisnika. Međutim, ne dolazi do zamjene identiteta, jer se taj dio očigledno vodi pod ID-jem u bazi.

Preporučam ti da se do daljnjega ne odlogiravaš s makar s jednog od računala koja koristiš.

Da i ja sam naknadno primjetio da su izmjenjeni samo podatci koji se pozivaju kroz url. Uglavnom već sam se izlogirao i mjenjao password te mail adresu budući da sam mislio da je account hakiran, tako da sa tim nema problema

Na prvu sam zaključio da je account hakiran jer sam otvorio “svoj” profil, i vidio krive podatke. Uglavno izgleda se radi o bezopasnoj greški, ali bilo bi dobro da se ispravi.

btw, tako je, moj avatar je pingvin

sigh rijesis jedan problem, nastane 5 novih. Uglavnom, vratio sam staru strukturu linkova za korisnicke profile, da li ti je sad profil opet vezan za postove i da li je samo avatar sad problem?
Apdejtao sam i vBulletin verziju s 4.1.10 na 4.1.12 pa je i tu mozda doslo do problema u bazi. A dan nakon stigne mi obavijest od vBulletina da je izasla verzija 4.2 :smiley:

[quote=“SteelMaiden”]sigh rijesis jedan problem, nastane 5 novih. Uglavnom, vratio sam staru strukturu linkova za korisnicke profile, da li ti je sad profil opet vezan za postove i da li je samo avatar sad problem?
Apdejtao sam i vBulletin verziju s 4.1.10 na 4.1.12 pa je i tu mozda doslo do problema u bazi. A dan nakon stigne mi obavijest od vBulletina da je izasla verzija 4.2 :D[/quote]

jesi updateao sve u General update tools? poslije svakog updatea napravim to da ne dodje do takvih problema…

[quote=“SteelMaiden”]sigh rijesis jedan problem, nastane 5 novih. Uglavnom, vratio sam staru strukturu linkova za korisnicke profile, da li ti je sad profil opet vezan za postove i da li je samo avatar sad problem?
Apdejtao sam i vBulletin verziju s 4.1.10 na 4.1.12 pa je i tu mozda doslo do problema u bazi. A dan nakon stigne mi obavijest od vBulletina da je izasla verzija 4.2 :D[/quote]

Koliko vidim sada je samo avatar ostao problem, jos uvijek njega prikazuje od drugog usera

Ok rijeseno.

primjetio sam jos jedan problem, neznam jel samo kod mene, uglavnom od jutros u topicima se pojedini postovi ne pokazuju. Vidi se da je netko nesto napisao, ali nema poruke. Recimo konkretno u ovom topicu se moj prvi post ne vidi. Neznam jel se ovo javlja samo meni ili i ostalima

I ja ne vidim :slight_smile:

također…

također ne vidim postove

ne vidim ni svoje postove :slight_smile:

Sad vidim drugi svoj post :slight_smile:

Broken :frowning:

1 jedan, jedan dva, 1 2 3 i laaaaaaa bl…
ps. radi, sve ponovno radi

[color="#FFFFFF"]Aha. Sad je sve u redu.[/color]

[color="#FFFFFF"]hm, malo vidim malo[/color] ne no nije [color="#FFFFFF"]mi jasno zašto?[/color]

A cemu ovo sluzi?


http://img651.imageshack.us/img651/6424/webme.jpg

Uploaded with ImageShack.us

Optimizacija web stranice se mjenja, tako da i linkovi mogu nestat s vremenom.


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Profit Monkey