Tvrd orah - automatska prijava ne radi (Joomla/Safari)

Pozdrav svima,

Imam jedan tvrd orah koji me muči već godinama pa ću ga podijeliti sa forumstvom, možda više glavi bude pametnije.

Radi se o jabucnjak.hr kojeg pokreće Joomla 1.0. Znam da se radi o staroj verziji međutim služi svrsi. Od verzije 2.0 Safari preglednika koja je izašla pred dosta godina više ne radi opcija “remember me” kod prijave. Ista stvar je i sa Chromeom, dakle to je specifično za WebKit.

Neko vrijeme sam proveo pokušavajući pronaći uzrok, međutim bez uspjeha. Sve i dalje dobro radi na Operi, Firefoxu, Exploreru i svemu ostalom. Sumnjam da je problem u cookijima zbog još jedne nuspojave - Safari korisnike modul za komentiranje često upiše kao “Anonymous” iako je korisnik prijavljen. Koliko sam kopao mislim da je problem u session cookieu, pa je vrlo vjerojatno da isti stvara problem i “remember me” kod prijave.

Trenutno čistim postepeno kupus od koda s nadom na se radi o nekom konfliktu, ali ne vjerujem da to može utjecati na opisani problem.

Proučio sam cookie koje Safari sprema i čine se najnormalniji, kao i kod ostalih browsera. Pogledao i php i apache logove i ne vidim ništa što bi mi bilo od pomoći. Od kuda krenuti? :frowning:

Nisam nikad riješavao takav problem, al evo jedne ideje za počet. Probaj dal radi na google chrome, on i safari rade na istoj matrici, samo što kod safarija ostavljene samo osnovne stvari da kao bude brži.
Još jedna stvar, kod joomla 1,5 (ne znam kako je kod 1,0) ima debug opcija, kako se krećeš po stranici ispisuje sql upite koji se šalju prem bazi, to može bit korisno ponekad, zna se desit da joomla iz nekoga razloga “pukne” na jos_session.

ein, sto se chromea tice napisao sam Ista stvar je i sa Chromeom, dakle to je specifično za WebKit. Milsim da je problem negdje izmedju servera i WebKita ali bacit cu oko na session tabelu iako sam siguran da tu nije problem jer se sessioni u tablici uredno updateaju - nakon sto se korisnik rucno prijavi.

sorry promaklo mi ono "isto je s chrome"
probao ukucat u google i često se dešavaju neki problemi s tim webkitom i joomlom
nemam ni jednu joomlu 1.0 instaliranu, al na 1,5 izgleda da sve ok i sa safarijem
ja bi prvo probao nadogradit joomlu na zadnju 1.0 verziju ako već nije na njoj, mislim da je to 1.0.15, ako ne uspije dalje je sve pogađanje gdje bi mogao bit problem


Copyright © 2020 WM Forum - AboutContact - Sponsored by: Mydataknox & Webmaster.Ninja